Discussion

« View full discussion


Discussion thread: 3 comments

» Reply 10.09.2010 19:47 | Bernhard Friedreich | web |
I tried removing .kdevduchain... didn't work..

Could it be related to the project not actually building (cmake wise)? because the autocompletion needs a working cmake project?
the project currently doesn't work because cmake doesn't find the moc files - so maybe the autocompletion dies because the project's cmake files can't be evaluated? *me makes wild guesses*
um... I don't know... it sometimes crashes if there is a syntax error, but on missing files? This doesn't cause the crash.

One last solution which could help with localizing the problem - try to install older version of kdevelop/kdevplatform (from 2010-09-04 and older) with non-patched kdelibs and check if that crashes too. If yes, "hooray", it's problem in KDevelop, if not, I'm screwed and the backport doesn't work (or I missed some more commits which should have been backported).
» Reply 11.09.2010 10:42 | Bernhard Friedreich | web |
wohoo! sorry for the noice but it works :)

the problem seems to have been nothing related to your kdelibs but instead my fucked up version of Qt in combination with an old kdevelop plugin (controlflow)

works now :)
good to backport imho

THANKS